News:
January 30, 2023, 08:06:01 PM

Author Topic: voltage imbalance with my speedball  (Read 518 times)

0 Members and 1 Guest are viewing this topic.

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
voltage imbalance with my speedball
« on: December 25, 2019, 05:12:50 PM »
I have installed the first board of the speedball, only to find that the voltage at OA reads 42v and 72 at OB.  I've reflowed, or in some cases cleaned and resautered, the connections all the way back to both tubes for that side of the amp.  Still it reads the same.  Any suggestions? 

Thanks in advance.

AGW
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #1 on: December 25, 2019, 06:49:16 PM »
Can you post a photo of your board?  I would bet you have a PN2907 installed backwards.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #2 on: December 26, 2019, 06:49:36 AM »
I have to use my phone for photos. Sorry for the delay.
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #3 on: December 26, 2019, 06:57:56 AM »
I just retested the voltage and it now measures 57v on OB but still 42 on OA. Both below the range of 60-90v the manual says the circuit requires.

IA reads 185v and IB 184.5v. B-BA reads 0v.

Thank you in advance for your help. I really appreciate you.

AGW
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #4 on: December 26, 2019, 07:02:48 AM »
Are the LEDs on the socket illuminating?  Was the amp working properly prior to installing the Speedball?  Can you post a photo of the bottom of the PC board?

It's important not to make any guesses at this point, but rather to collect a complete set of information.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #5 on: December 26, 2019, 07:15:47 AM »
All leds light up. Amp worked fine before. Attached is the photo
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #6 on: December 26, 2019, 07:27:45 AM »
All leds light up.
For every joint on the bottom of that PC board other than the ones for the LEDs, reheat them with your soldering iron until the solder melts, then count to ten.

The LEDs lighting up tell me that your tubes are glowing and that the board is passing some current.  The really low plate voltage in combination with the illuminated LEDs tells me that the amount of current passing through is very, very low, which is almost always a solder joint issue. 
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #7 on: December 26, 2019, 10:23:28 AM »
I have re-soldered every point on the board except the leds twice.  I even reflowed all the joints on that side of the amp circuit.  the volts are now up on the OB side.  It reads 64V.  The OA side reads 41V. 

AGW
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #8 on: December 26, 2019, 10:24:22 AM »
So this is some good evidence that solder joints are an issue, and the improvement demonstrates the need for a lot more heat.

What is the wattage rating of your soldering iron?
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #9 on: December 26, 2019, 10:35:36 AM »
I have a new Vastar iron that I ordered.  I have it turned all the way up to 8.  When I did the board though, I used the finest tip that came with it.  I had a hard time getting it hot, as I now recall.  I'm now using the larger tip. 

AGW
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #10 on: December 26, 2019, 10:45:28 AM »
OK, that looks like a 60W iron.  You want it cranked up all the way for sure. 
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #11 on: December 26, 2019, 12:00:00 PM »
Well I have soldered and resoldered everything on the board. 

The voltage on the two outside legs of both Q2A and Q2B are 181V.  The center leg on Q2A is 40v.  The center leg on Q2B is 57V.  That seems odd to me. 

AGW
Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #12 on: December 26, 2019, 01:02:34 PM »
I would go ahead and give the LED solder joints on the board a bit of reheating as well.  Looking at the images again, I can see at least one LED joint that isn't all the way flowed.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Agweeks

  • Jr. Member
  • **
  • Posts: 41
Re: voltage imbalance with my speedball
« Reply #13 on: December 27, 2019, 02:19:11 PM »
As we discussed over the phone, I have a broken LED's on the 9 pin tube socket.  I've ordered more from you guys. 

You mentioned that I could temporarily create a jumper?  From where to where would I do so?

Adam Weeks

Well Tempered Turntable, Sumiko Blue Point 2, Schitt Mani, Stereomour II, Klipsch La Scalas

Schiit BiFrost, Bottlehead Crack/Speedball, Sennheiser HD 6xx

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 17914
Re: voltage imbalance with my speedball
« Reply #14 on: December 27, 2019, 03:08:28 PM »
Just a piece of wire to connect A3 and A8.

-PB
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man