News: Trouble logging in? Log in from the login page.
October 31, 2020, 12:13:49 PM

Author Topic: Damaged Quicksand  (Read 201 times)

0 Members and 1 Guest are viewing this topic.

Offline oguinn

  • Sr. Member
  • ****
  • Posts: 686
    • DIY Audio Gallery
Damaged Quicksand
« on: September 24, 2020, 01:46:09 PM »
Today in a little bit of a huff I tried knocking a dowel into a piece of wood with a hammer on the table my combo quicksand/quickie is sitting on. At first there was what sounded like a skipping CD sort of pattern, and now it won’t play anything out of the right channel and only clicks, about 2 per second, out of the left channel.

I did the chopstick test but came up empty. Any suggestions on what to look at? It’s not a hugely complex build, I guess, but it seems like there’s a problem with the opamp?
Jameson O’Guinn

-

Main System: Schiit Bifrost MB, Schiit Sol, Eros 2, BeePre, Kaiju/Stereomour II, Jägers, Mainline

Desktop System: Crack with Speedball

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 13738
Re: Damaged Quicksand
« Reply #1 on: September 24, 2020, 02:59:52 PM »
You can pull the amp out of the socket and replace it.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline oguinn

  • Sr. Member
  • ****
  • Posts: 686
    • DIY Audio Gallery
Re: Damaged Quicksand
« Reply #2 on: September 24, 2020, 03:13:36 PM »
I did do that with no change, should have mentioned that
Jameson O’Guinn

-

Main System: Schiit Bifrost MB, Schiit Sol, Eros 2, BeePre, Kaiju/Stereomour II, Jägers, Mainline

Desktop System: Crack with Speedball

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 13738
Re: Damaged Quicksand
« Reply #3 on: September 24, 2020, 05:40:08 PM »
Are the batteries well seated? Dead? 

There could just be a loose connection.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline oguinn

  • Sr. Member
  • ****
  • Posts: 686
    • DIY Audio Gallery
Re: Damaged Quicksand
« Reply #4 on: September 24, 2020, 06:17:04 PM »
They seemed well-seated. I’ll check the battery wiring tomorrow. I don’t think they’re dead; the timing would be a huge coincidence given that it seemed like a response to the vibrations from hammering.

I assume there’s very little likelihood the amp itself died from the vibration or ringing from the Quickie’s tubes or anything, right?
Jameson O’Guinn

-

Main System: Schiit Bifrost MB, Schiit Sol, Eros 2, BeePre, Kaiju/Stereomour II, Jägers, Mainline

Desktop System: Crack with Speedball

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 13738
Re: Damaged Quicksand
« Reply #5 on: September 24, 2020, 06:18:23 PM »
It's most likely that a dodgy connection rattled loose.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline oguinn

  • Sr. Member
  • ****
  • Posts: 686
    • DIY Audio Gallery
Re: Damaged Quicksand
« Reply #6 on: October 01, 2020, 08:55:09 AM »
Just pulled the board out and resoldered everything, then ran new wire to many parts of the amp. Seems to be working.

Question: do you guys have any spare boards for this or the Quickie running around? I lifted some of the pads off when reheating the board and was able to use adjacent holes for those, but subsequent repairs (should they be necessary) are going to be really difficult.
Jameson O’Guinn

-

Main System: Schiit Bifrost MB, Schiit Sol, Eros 2, BeePre, Kaiju/Stereomour II, Jägers, Mainline

Desktop System: Crack with Speedball

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 13738
Re: Damaged Quicksand
« Reply #7 on: October 01, 2020, 09:23:58 AM »
I can look around, I might have some spare boards, or we may have simply sold them out.
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline oguinn

  • Sr. Member
  • ****
  • Posts: 686
    • DIY Audio Gallery
Re: Damaged Quicksand
« Reply #8 on: October 01, 2020, 09:25:06 AM »
Yeah let me know. I’ve retired this combo quicksand and quickie from shop duty until I can get it into a less vibration-prone spot, but it’d be nice to have some backups just in case.
Jameson O’Guinn

-

Main System: Schiit Bifrost MB, Schiit Sol, Eros 2, BeePre, Kaiju/Stereomour II, Jägers, Mainline

Desktop System: Crack with Speedball

Offline Doc B.

  • Administrator
  • Hero Member
  • *****
  • Posts: 8277
    • Bottlehead
Re: Damaged Quicksand
« Reply #9 on: October 01, 2020, 10:05:35 AM »
I see a few chips and sockets in a box in the warehouse, but there are no more boards.
Dan "Doc B." Schmalle
President For Life
Bottlehead Corp.

Offline oguinn

  • Sr. Member
  • ****
  • Posts: 686
    • DIY Audio Gallery
Re: Damaged Quicksand
« Reply #10 on: October 01, 2020, 10:08:31 AM »
Ah well. Shoulda kept that second pair of each instead of selling them. Thanks Doc
Jameson O’Guinn

-

Main System: Schiit Bifrost MB, Schiit Sol, Eros 2, BeePre, Kaiju/Stereomour II, Jägers, Mainline

Desktop System: Crack with Speedball