News:
November 26, 2021, 03:53:21 PM

Author Topic: Loud poping sound when turning off Paramount 300B  (Read 499 times)

0 Members and 1 Guest are viewing this topic.

Offline Anton

  • Full Member
  • ***
  • Posts: 72
Loud poping sound when turning off Paramount 300B
« on: January 20, 2021, 09:20:25 AM »
Hello,
I have Eros Phono feeding into Foreplay III extended upgrade and Paramount 300B monoblocs (without soft start) - driving Cain&Cain Abby speakers.
When I turn on my stereo I start with Eros first, then turn on Foreplay (with volume knobs down to zero), then I turn on monoblocks. After that, I adjust volume as needed.
When I turn my stereo off, I start by turning the volume down to zero, after that, I turn off, monoblocks and last I shut down the phono stage.

My problem is this: when I turn on Paramounts, after 3-4 seconds my speakers make this pop sound, not very loud though so it doesn't bother me much. 
But when I turn off monoblocks, my speakers make a pretty loud and ugly sounding popping sound (even though the volume knob on pre-amp is down to zero). I am wondering if that can blow my speakers. And the interesting thing is if I disconnect Foreplay from Paramounts before shutting Paramounts down, there is no pop. Did anyone else had a similar experience and what should I do?

When I am using SEX 2.1 with the speakers I don't have such a problem.

Thanks in advance for feedback
« Last Edit: January 20, 2021, 09:28:46 AM by Anton »
Eros phono / Foreplay III extended upgrade / Paramount 300B/ S.E.X. 2.1 impedance switch upgrade

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 15804
Re: Loud poping sound when turning off Paramount 300B
« Reply #1 on: January 20, 2021, 09:35:05 AM »
if I disconnect Foreplay from Paramounts before shutting Paramounts down, there is no pop.
That's really, really odd.  I would definitely recommend measuring the voltages in the Paramounts and Foreplay to be sure they are working properly.  How is the grounding where you live?  Are all the outlets earthed?
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man

Offline Anton

  • Full Member
  • ***
  • Posts: 72
Re: Loud poping sound when turning off Paramount 300B
« Reply #2 on: January 20, 2021, 10:13:47 AM »
Paul,
Thank you very much.
I checked the ground wire running from my turntable to the grounding post on Eros. It turned out that it got disconnected on turntable side and I didn't notice that. I re-connected the grounding wire and it made it much better. I still can hear audible pop when I turn off the power amp, but it is not nearly as violent as before.
As for the grounding of outlets, I am not sure but I never had serious issues with that before. Also, I am using PS Audio Power Plant to plug all my components into.
Eros phono / Foreplay III extended upgrade / Paramount 300B/ S.E.X. 2.1 impedance switch upgrade

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 15804
Re: Loud poping sound when turning off Paramount 300B
« Reply #3 on: January 20, 2021, 10:59:30 AM »
Hmm, you could definitely try not using the PS Audio Power Plant to see if that makes a difference.  If the turntable wire made a big change, I would suspect that there might be earthing issues related to your AC mains. 
Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man