News:
July 05, 2022, 12:33:23 AM

Author Topic: SEX Kit Amp stoped working  (Read 198 times)

0 Members and 1 Guest are viewing this topic.

Offline LouisQ

  • Jr. Member
  • **
  • Posts: 13
SEX Kit Amp stoped working
« on: December 24, 2021, 01:39:44 PM »
Hi,

Everything was going well with my SEX amp for the last few months but suddenly tonight it just stopped dead (no lights in the tube/no sound). The fuse seems OK (though, oddly it’s a 2A/250 V inside).

Would someone have any suggestions on how to troubleshoot it (pictures Att.) ?

Thank you in advance for your help.

Louis

Offline Doc B.

  • Administrator
  • Hero Member
  • *****
  • Posts: 9028
    • Bottlehead
Re: SEX Kit Amp stoped working
« Reply #1 on: December 24, 2021, 02:05:03 PM »
"Fuse seems OK". Did you verify the function of the fuse by measuring its resistance?
Dan "Doc B." Schmalle
President For Life
Bottlehead Corp.

Offline Natural Sound

  • Sr. Member
  • ****
  • Posts: 966
Re: SEX Kit Amp stoped working
« Reply #2 on: December 24, 2021, 02:16:39 PM »
Hi Louis,

Being that it's the holidays you may not get a response from the Bottlehead folks for a day or so. The photo you posted of the fuse "looks" OK but measuring it with your meter on the resistance scale would be a better indicator of it's condition. You should read 0 ohms or thereabouts. I believe that the recommendation of the BH team will be to perform the resistance checks in the manual and post any anomalies here. Also, you might want to use a magnifying glass and check all the solder connections in your amp. I'd pay especially close attention around the IEC power socket, power transformer and diodes. Re-flow any connections that look questionable. Refer to page 63 in the manual for additional troubleshooting tips.

Tom AKA Natural Sound

Offline Natural Sound

  • Sr. Member
  • ****
  • Posts: 966
Re: SEX Kit Amp stoped working
« Reply #3 on: December 24, 2021, 02:18:05 PM »
Oh, I see that Doc B showed up while I was typing. I hope I didn't overstep my bounds.

Offline LouisQ

  • Jr. Member
  • **
  • Posts: 13
Re: SEX Kit Amp stoped working
« Reply #4 on: December 24, 2021, 02:46:31 PM »
Thank you both,

I will go ahead and proceed with your suggestions, and keep you posted with the results.

In the meantime, happy holidays :)





« Last Edit: December 24, 2021, 02:57:17 PM by LouisQ »

Offline Paul Birkeland

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 16941
Re: SEX Kit Amp stoped working
« Reply #5 on: December 24, 2021, 05:15:20 PM »
If the fuse is OK, do a voltage check.  If the tubes aren't glowing but you see some high DC voltages where there should be high DC voltages, that kind of information would be enough to go on.

Paul "PB" Birkeland

Bottlehead Grunt & The Repro Man